import Foundation
let pattern = #"^(?:(?:\d{4}) (?:\d{3}) (?:\d{3})|(?:\d{2}) (?:\d{2}) (?:\d{2})|(?:\d{2}) (?:\d{4}) (?:\d{4})|(?:\d{4}) (?:\d{4}))$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
02 1234 5678
0412 345 678
1800 123 456
1300 123 456
13 12 34
1900 123 456
1902 123 456
1234 5678
02 25 45
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)