// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?:(?:\d{4}) (?:\d{3}) (?:\d{3})|(?:\d{2}) (?:\d{2}) (?:\d{2})|(?:\d{2}) (?:\d{4}) (?:\d{4})|(?:\d{4}) (?:\d{4}))$").unwrap();
let string = "02 1234 5678
0412 345 678
1800 123 456
1300 123 456
13 12 34
1900 123 456
1902 123 456
1234 5678
02 25 45
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}