$re = '/^(?:(?:\d{4}) (?:\d{3}) (?:\d{3})|(?:\d{2}) (?:\d{2}) (?:\d{2})|(?:\d{2}) (?:\d{4}) (?:\d{4})|(?:\d{4}) (?:\d{4}))$/';
$str = '02 1234 5678
0412 345 678
1800 123 456
1300 123 456
13 12 34
1900 123 456
1902 123 456
1234 5678
02 25 45
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);