#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?:(?:\d{4}) (?:\d{3}) (?:\d{3})|(?:\d{2}) (?:\d{2}) (?:\d{2})|(?:\d{2}) (?:\d{4}) (?:\d{4})|(?:\d{4}) (?:\d{4}))$"
Local $sString = "02 1234 5678" & @CRLF & _
"0412 345 678" & @CRLF & _
"1800 123 456" & @CRLF & _
"1300 123 456" & @CRLF & _
"13 12 34" & @CRLF & _
"1900 123 456" & @CRLF & _
"1902 123 456" & @CRLF & _
"1234 5678" & @CRLF & _
"" & @CRLF & _
"02 25 45" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")