const regex = /^(?:(?:\d{4}) (?:\d{3}) (?:\d{3})|(?:\d{2}) (?:\d{2}) (?:\d{2})|(?:\d{2}) (?:\d{4}) (?:\d{4})|(?:\d{4}) (?:\d{4}))$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:\\d{4}) (?:\\d{3}) (?:\\d{3})|(?:\\d{2}) (?:\\d{2}) (?:\\d{2})|(?:\\d{2}) (?:\\d{4}) (?:\\d{4})|(?:\\d{4}) (?:\\d{4}))$', 'g')
const str = `02 1234 5678
0412 345 678
1800 123 456
1300 123 456
13 12 34
1900 123 456
1902 123 456
1234 5678
02 25 45
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}