import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\d{4}) (?:\\d{3}) (?:\\d{3})|(?:\\d{2}) (?:\\d{2}) (?:\\d{2})|(?:\\d{2}) (?:\\d{4}) (?:\\d{4})|(?:\\d{4}) (?:\\d{4}))$";
final String string = "02 1234 5678\n"
+ "0412 345 678\n"
+ "1800 123 456\n"
+ "1300 123 456\n"
+ "13 12 34\n"
+ "1900 123 456\n"
+ "1902 123 456\n"
+ "1234 5678\n\n"
+ "02 25 45\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}