# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[€]\s(1?[5]000|[1-9]{1}[5,0]{1,3}([0]{3,10}))$"
test_str = ("€ 5000\n"
"€ 3000\n"
"€ 10000\n"
"€ 13000\n"
"€ 20000\n\n"
"€ 5000\n"
"€ 3000\n"
"€ 100000\n"
"€ 13000\n"
"€ 200000\n\n"
"€ 200000000000\n\n"
"€ 255000\n\n"
"€ 2555000\n"
"€ 255000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.