package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[€]\s(1?[5]000|[1-9]{1}[5,0]{1,3}([0]{3,10}))$`)
var str = `€ 5000
€ 3000
€ 10000
€ 13000
€ 20000
€ 5000
€ 3000
€ 100000
€ 13000
€ 200000
€ 200000000000
€ 255000
€ 2555000
€ 255000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}