import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[€]\\s(1?[5]000|[1-9]{1}[5,0]{1,3}([0]{3,10}))$";
final String string = "€ 5000\n"
+ "€ 3000\n"
+ "€ 10000\n"
+ "€ 13000\n"
+ "€ 20000\n\n"
+ "€ 5000\n"
+ "€ 3000\n"
+ "€ 100000\n"
+ "€ 13000\n"
+ "€ 200000\n\n"
+ "€ 200000000000\n\n"
+ "€ 255000\n\n"
+ "€ 2555000\n"
+ "€ 255000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}