using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[€]\s(1?[5]000|[1-9]{1}[5,0]{1,3}([0]{3,10}))$";
string input = @"€ 5000
€ 3000
€ 10000
€ 13000
€ 20000
€ 5000
€ 3000
€ 100000
€ 13000
€ 200000
€ 200000000000
€ 255000
€ 2555000
€ 255000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}