$re = '/^[€]\s(1?[5]000|[1-9]{1}[5,0]{1,3}([0]{3,10}))$/m';
$str = '€ 5000
€ 3000
€ 10000
€ 13000
€ 20000
€ 5000
€ 3000
€ 100000
€ 13000
€ 200000
€ 200000000000
€ 255000
€ 2555000
€ 255000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);