#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[€]\s(1?[5]000|[1-9]{1}[5,0]{1,3}([0]{3,10}))$"
Local $sString = "€ 5000" & @CRLF & _
"€ 3000" & @CRLF & _
"€ 10000" & @CRLF & _
"€ 13000" & @CRLF & _
"€ 20000" & @CRLF & _
"" & @CRLF & _
"€ 5000" & @CRLF & _
"€ 3000" & @CRLF & _
"€ 100000" & @CRLF & _
"€ 13000" & @CRLF & _
"€ 200000" & @CRLF & _
"" & @CRLF & _
"€ 200000000000" & @CRLF & _
"" & @CRLF & _
"€ 255000" & @CRLF & _
"" & @CRLF & _
"€ 2555000" & @CRLF & _
"€ 255000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")