// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?'asset'02)_(?'market1'\w{3,})\/(?'market2'\w{3,})_(?'type'M)(?'offset'L)_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\d{4})-\b(?'month'0[1-9]|1[0-2])\b$").unwrap();
let string = "02_AUT/TTF_H_ML_PHY M-2015-12
02_AUT/TTF_H_ML_PHY M-2016-01
02_GASPOOL_L/GASPOOL_H_ML_PHY M-2015-12
02_GASPOOL_L/GASPOOL_H_ML_PHY M-2016-01";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}