$re = '/^(?\'asset\'02)_(?\'market1\'\w{3,})\/(?\'market2\'\w{3,})_(?\'type\'M)(?\'offset\'L)_(?\'derivative\'PHY|FUT) (?\'period\'M)-(?\'year\'\d{4})-\b(?\'month\'0[1-9]|1[0-2])\b$/m';
$str = '02_AUT/TTF_H_ML_PHY M-2015-12
02_AUT/TTF_H_ML_PHY M-2016-01
02_GASPOOL_L/GASPOOL_H_ML_PHY M-2015-12
02_GASPOOL_L/GASPOOL_H_ML_PHY M-2016-01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);