import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'asset'02)_(?'market1'\\w{3,})\\/(?'market2'\\w{3,})_(?'type'M)(?'offset'L)_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\\d{4})-\\b(?'month'0[1-9]|1[0-2])\\b$";
final String string = "02_AUT/TTF_H_ML_PHY M-2015-12\n"
+ "02_AUT/TTF_H_ML_PHY M-2016-01\n"
+ "02_GASPOOL_L/GASPOOL_H_ML_PHY M-2015-12\n"
+ "02_GASPOOL_L/GASPOOL_H_ML_PHY M-2016-01";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}