#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?'asset'02)_(?'market1'\w{3,})\/(?'market2'\w{3,})_(?'type'M)(?'offset'L)_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\d{4})-\b(?'month'0[1-9]|1[0-2])\b$"
Local $sString = "02_AUT/TTF_H_ML_PHY M-2015-12" & @CRLF & _
"02_AUT/TTF_H_ML_PHY M-2016-01" & @CRLF & _
"02_GASPOOL_L/GASPOOL_H_ML_PHY M-2015-12" & @CRLF & _
"02_GASPOOL_L/GASPOOL_H_ML_PHY M-2016-01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")