use strict;
my $str = '02_AUT/TTF_H_ML_PHY M-2015-12
02_AUT/TTF_H_ML_PHY M-2016-01
02_GASPOOL_L/GASPOOL_H_ML_PHY M-2015-12
02_GASPOOL_L/GASPOOL_H_ML_PHY M-2016-01';
my $regex = qr/^(?'asset'02)_(?'market1'\w{3,})\/(?'market2'\w{3,})_(?'type'M)(?'offset'L)_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\d{4})-\b(?'month'0[1-9]|1[0-2])\b$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}