using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?'asset'02)_(?'market1'\w{3,})\/(?'market2'\w{3,})_(?'type'M)(?'offset'L)_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\d{4})-\b(?'month'0[1-9]|1[0-2])\b$";
string input = @"02_AUT/TTF_H_ML_PHY M-2015-12
02_AUT/TTF_H_ML_PHY M-2016-01
02_GASPOOL_L/GASPOOL_H_ML_PHY M-2015-12
02_GASPOOL_L/GASPOOL_H_ML_PHY M-2016-01";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}