// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)((LOOP\s+AT\s+\w*\s+INTO\s+\w*(.?)\s+)((INSERT|DELETE|UPDATE|MODIFY)\s+(\w*\.?\*?\s+)*(FROM\s+\w*\.\s*)?(ENDLOOP\.)))
").unwrap();
let string = "LOOP AT TAB
INTO TAB_WA.
INSERT INTO CUSTOMERS VALUES TAB_WA.
ENDLOOP.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}