package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)((LOOP\s+AT\s+\w*\s+INTO\s+\w*(.?)\s+)((INSERT|DELETE|UPDATE|MODIFY)\s+(\w*\.?\*?\s+)*(FROM\s+\w*\.\s*)?(ENDLOOP\.)))
`)
var str = `LOOP AT TAB
INTO TAB_WA.
INSERT INTO CUSTOMERS VALUES TAB_WA.
ENDLOOP.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}