import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((LOOP\\s+AT\\s+\\w*\\s+INTO\\s+\\w*(.?)\\s+)((INSERT|DELETE|UPDATE|MODIFY)\\s+(\\w*\\.?\\*?\\s+)*(FROM\\s+\\w*\\.\\s*)?(ENDLOOP\\.)))\n\n";
final String string = "LOOP AT TAB \n"
+ " INTO TAB_WA.\n"
+ " INSERT INTO CUSTOMERS VALUES TAB_WA.\n"
+ "ENDLOOP.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}