const regex = /((LOOP\s+AT\s+\w*\s+INTO\s+\w*(.?)\s+)((INSERT|DELETE|UPDATE|MODIFY)\s+(\w*\.?\*?\s+)*(FROM\s+\w*\.\s*)?(ENDLOOP\.)))
/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((LOOP\\s+AT\\s+\\w*\\s+INTO\\s+\\w*(.?)\\s+)((INSERT|DELETE|UPDATE|MODIFY)\\s+(\\w*\\.?\\*?\\s+)*(FROM\\s+\\w*\\.\\s*)?(ENDLOOP\\.)))
', 'gmi')
const str = `LOOP AT TAB
INTO TAB_WA.
INSERT INTO CUSTOMERS VALUES TAB_WA.
ENDLOOP.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}