re = /((LOOP\s+AT\s+\w*\s+INTO\s+\w*(.?)\s+)((INSERT|DELETE|UPDATE|MODIFY)\s+(\w*\.?\*?\s+)*(FROM\s+\w*\.\s*)?(ENDLOOP\.)))
/mi
str = 'LOOP AT TAB
INTO TAB_WA.
INSERT INTO CUSTOMERS VALUES TAB_WA.
ENDLOOP.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end