use strict;
my $str = 'LOOP AT TAB
INTO TAB_WA.
INSERT INTO CUSTOMERS VALUES TAB_WA.
ENDLOOP.
';
my $regex = qr/((LOOP\s+AT\s+\w*\s+INTO\s+\w*(.?)\s+)((INSERT|DELETE|UPDATE|MODIFY)\s+(\w*\.?\*?\s+)*(FROM\s+\w*\.\s*)?(ENDLOOP\.)))
/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}