import Foundation
let pattern = #"^(((I|i)nitial|(F|f)irst)\scommit)|((I|i)nit)$|^(?=.{6,72}$)(feat|(bug|hot)?fix|docs|perf|style|wip|test|revert|chore|ci|refactor|build)(\([a-zA-Z0-9\-\s,]{1,50}\))?:\s(.{1,50})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
?# https://www.conventionalcommits.org/en/v1.0.0/
Initial commit
initial commit
Init
init
First commit
first commit
?# Correct
feat(foo): new feature
bugfix(bar): fix this and that
docs(foo): document new feature
docs(foo, egg): multiple scopes is fine
feat: no scope here
?# Wrong
feat:missing a space
docs(): no empty scope
fix(/.%): invalid characters
Initial
initial
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)