$re = '/^(((I|i)nitial|(F|f)irst)\scommit)|((I|i)nit)$|^(?=.{6,72}$)(feat|(bug|hot)?fix|docs|perf|style|wip|test|revert|chore|ci|refactor|build)(\([a-zA-Z0-9\-\s,]{1,50}\))?:\s(.{1,50})$/m';
$str = '?# https://www.conventionalcommits.org/en/v1.0.0/
Initial commit
initial commit
Init
init
First commit
first commit
?# Correct
feat(foo): new feature
bugfix(bar): fix this and that
docs(foo): document new feature
docs(foo, egg): multiple scopes is fine
feat: no scope here
?# Wrong
feat:missing a space
docs(): no empty scope
fix(/.%): invalid characters
Initial
initial
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);