# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(((I|i)nitial|(F|f)irst)\scommit)|((I|i)nit)$|^(?=.{6,72}$)(feat|(bug|hot)?fix|docs|perf|style|wip|test|revert|chore|ci|refactor|build)(\([a-zA-Z0-9\-\s,]{1,50}\))?:\s(.{1,50})$"
test_str = ("?# https://www.conventionalcommits.org/en/v1.0.0/\n\n"
"Initial commit\n"
"initial commit\n"
"Init\n"
"init\n"
"First commit\n"
"first commit\n\n"
"?# Correct\n"
"feat(foo): new feature\n"
"bugfix(bar): fix this and that\n"
"docs(foo): document new feature\n"
"docs(foo, egg): multiple scopes is fine\n"
"feat: no scope here\n\n"
"?# Wrong\n\n"
"feat:missing a space\n"
"docs(): no empty scope\n"
"fix(/.%): invalid characters\n"
"Initial\n"
"initial\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.