import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((I|i)nitial|(F|f)irst)\\scommit)|((I|i)nit)$|^(?=.{6,72}$)(feat|(bug|hot)?fix|docs|perf|style|wip|test|revert|chore|ci|refactor|build)(\\([a-zA-Z0-9\\-\\s,]{1,50}\\))?:\\s(.{1,50})$";
final String string = "?# https://www.conventionalcommits.org/en/v1.0.0/\n\n"
+ "Initial commit\n"
+ "initial commit\n"
+ "Init\n"
+ "init\n"
+ "First commit\n"
+ "first commit\n\n"
+ "?# Correct\n"
+ "feat(foo): new feature\n"
+ "bugfix(bar): fix this and that\n"
+ "docs(foo): document new feature\n"
+ "docs(foo, egg): multiple scopes is fine\n"
+ "feat: no scope here\n\n"
+ "?# Wrong\n\n"
+ "feat:missing a space\n"
+ "docs(): no empty scope\n"
+ "fix(/.%): invalid characters\n"
+ "Initial\n"
+ "initial\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}