const regex = /^(((I|i)nitial|(F|f)irst)\scommit)|((I|i)nit)$|^(?=.{6,72}$)(feat|(bug|hot)?fix|docs|perf|style|wip|test|revert|chore|ci|refactor|build)(\([a-zA-Z0-9\-\s,]{1,50}\))?:\s(.{1,50})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((I|i)nitial|(F|f)irst)\\scommit)|((I|i)nit)$|^(?=.{6,72}$)(feat|(bug|hot)?fix|docs|perf|style|wip|test|revert|chore|ci|refactor|build)(\\([a-zA-Z0-9\\-\\s,]{1,50}\\))?:\\s(.{1,50})$', 'gm')
const str = `?# https://www.conventionalcommits.org/en/v1.0.0/
Initial commit
initial commit
Init
init
First commit
first commit
?# Correct
feat(foo): new feature
bugfix(bar): fix this and that
docs(foo): document new feature
docs(foo, egg): multiple scopes is fine
feat: no scope here
?# Wrong
feat:missing a space
docs(): no empty scope
fix(/.%): invalid characters
Initial
initial
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}