use strict;
my $str = '?# https://www.conventionalcommits.org/en/v1.0.0/
Initial commit
initial commit
Init
init
First commit
first commit
?# Correct
feat(foo): new feature
bugfix(bar): fix this and that
docs(foo): document new feature
docs(foo, egg): multiple scopes is fine
feat: no scope here
?# Wrong
feat:missing a space
docs(): no empty scope
fix(/.%): invalid characters
Initial
initial
';
my $regex = qr/^(((I|i)nitial|(F|f)irst)\scommit)|((I|i)nit)$|^(?=.{6,72}$)(feat|(bug|hot)?fix|docs|perf|style|wip|test|revert|chore|ci|refactor|build)(\([a-zA-Z0-9\-\s,]{1,50}\))?:\s(.{1,50})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}