// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<first_sentence>.*[.?!])\s+(?<second_sentence>.*)\n").unwrap();
let string = "assumes word senses. Within
he arrive.\" After she had
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}