use strict;
my $str = 'assumes word senses. Within
he arrive." After she had
';
my $regex = qr/(?<first_sentence>.*[.?!])\s+(?<second_sentence>.*)\n/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";