$re = '/(?<first_sentence>.*[.?!])\s+(?<second_sentence>.*)\n/m';
$str = 'assumes word senses. Within
he arrive." After she had
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;