const regex = /(?<first_sentence>.*[.?!])\s+(?<second_sentence>.*)\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<first_sentence>.*[.?!])\\s+(?<second_sentence>.*)\\n', 'gm')
const str = `assumes word senses. Within
he arrive." After she had
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);