re = /(?<first_sentence>.*[.?!])\s+(?<second_sentence>.*)\n/m
str = 'assumes word senses. Within
he arrive." After she had
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result