re = /(?:(?<=\.(?:com|cn)(\:\d+(?!\d)))|(?<=\.(?:com|cn)(?!:\d+|\.)))(?!\/)/
str = 'https://live-rv.duizhuang.com:123aaa/bb
https://live-rv.duizhuang.com:123/aaa/bb
https://live-rv.duizhuang.com/aaa/bb
https://live-rv.duizhuang.cn2/aaa/bb
https://img.dz8.cn/2/aaa/bb.png!/1/1
'
subst = '/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result