# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?<=\.(?:com|cn)(\:\d+(?!\d)))|(?<=\.(?:com|cn)(?!:\d+|\.)))(?!\/)"
test_str = ("https://live-rv.duizhuang.com:123aaa/bb\n\n"
"https://live-rv.duizhuang.com:123/aaa/bb\n\n"
"https://live-rv.duizhuang.com/aaa/bb\n\n"
"https://live-rv.duizhuang.cn2/aaa/bb\n\n"
"https://img.dz8.cn/2/aaa/bb.png!/1/1\n\n")
subst = "/"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.