const regex = /(?:(?<=\.(?:com|cn)(\:\d+(?!\d)))|(?<=\.(?:com|cn)(?!:\d+|\.)))(?!\/)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<=\\.(?:com|cn)(\\:\\d+(?!\\d)))|(?<=\\.(?:com|cn)(?!:\\d+|\\.)))(?!\\\/)', 'g')
const str = `https://live-rv.duizhuang.com:123aaa/bb
https://live-rv.duizhuang.com:123/aaa/bb
https://live-rv.duizhuang.com/aaa/bb
https://live-rv.duizhuang.cn2/aaa/bb
https://img.dz8.cn/2/aaa/bb.png!/1/1
`;
const subst = `/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);