# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?<=\.(?:com|cn)(\:\d+(?!\d)))|(?<=\.(?:com|cn)(?!:\d+|\.)))(?!\\/)/\//g;t' <<< "https://live-rv.duizhuang.com:123aaa/bb
https://live-rv.duizhuang.com:123/aaa/bb
https://live-rv.duizhuang.com/aaa/bb
https://live-rv.duizhuang.cn2/aaa/bb
https://img.dz8.cn/2/aaa/bb.png!/1/1
"