#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:(?<=\.(?:com|cn)(\:\d+(?!\d)))|(?<=\.(?:com|cn)(?!:\d+|\.)))(?!\/)"
Local $sString = "https://live-rv.duizhuang.com:123aaa/bb" & @CRLF & _
"" & @CRLF & _
"https://live-rv.duizhuang.com:123/aaa/bb" & @CRLF & _
"" & @CRLF & _
"https://live-rv.duizhuang.com/aaa/bb" & @CRLF & _
"" & @CRLF & _
"https://live-rv.duizhuang.cn2/aaa/bb" & @CRLF & _
"" & @CRLF & _
"https://img.dz8.cn/2/aaa/bb.png!/1/1" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)