import Foundation
let pattern = #"^\??[a-z]+(_[a-z]+)*$|^\??(_[a-z]+){2,}(>[a-z]+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
_cosa_cosa_cosa>cosa
cosa
?cosa
?_cosa_cosa
_cosa_cosa
cosa_cosa
cosa_
_cosa
?_cosa
?_cosa_
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)