$re = '/^\??[a-z]+(_[a-z]+)*$|^\??(_[a-z]+){2,}(>[a-z]+)?$/m';
$str = '_cosa_cosa_cosa>cosa
cosa
?cosa
?_cosa_cosa
_cosa_cosa
cosa_cosa
cosa_
_cosa
?_cosa
?_cosa_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);