package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\??[a-z]+(_[a-z]+)*$|^\??(_[a-z]+){2,}(>[a-z]+)?$`)
var str = `_cosa_cosa_cosa>cosa
cosa
?cosa
?_cosa_cosa
_cosa_cosa
cosa_cosa
cosa_
_cosa
?_cosa
?_cosa_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}