using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\??[a-z]+(_[a-z]+)*$|^\??(_[a-z]+){2,}(>[a-z]+)?$";
string input = @"_cosa_cosa_cosa>cosa
cosa
?cosa
?_cosa_cosa
_cosa_cosa
cosa_cosa
cosa_
_cosa
?_cosa
?_cosa_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}