re = /^\??[a-z]+(_[a-z]+)*$|^\??(_[a-z]+){2,}(>[a-z]+)?$/m
str = '_cosa_cosa_cosa>cosa
cosa
?cosa
?_cosa_cosa
_cosa_cosa
cosa_cosa
cosa_
_cosa
?_cosa
?_cosa_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end