import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\??[a-z]+(_[a-z]+)*$|^\\??(_[a-z]+){2,}(>[a-z]+)?$";
final String string = "_cosa_cosa_cosa>cosa\n"
+ "cosa\n"
+ "?cosa\n"
+ "?_cosa_cosa\n"
+ "_cosa_cosa\n"
+ "cosa_cosa\n"
+ "cosa_\n"
+ "_cosa\n"
+ "?_cosa\n"
+ "?_cosa_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}