import Foundation
let pattern = #"^(personal-loan|yourmortgageapp|lending).wf.com|^wellsfargo.com|^apply.wellsfargo.com"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
wellsfargo.com
apply.wellsfargo.com
wapppply.wellsfargo.com
test.wellsfargo.com
lending.wf.com
lending-loans.wf.com
yourmortgageapp.wf.com
personal-loan.wf.com
personalloans.wf.com
wellsfargo.com/werasefefraewr/adsfgdsfgsdfrg/dersgesrg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)