#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(personal-loan|yourmortgageapp|lending).wf.com|^wellsfargo.com|^apply.wellsfargo.com"
Local $sString = "wellsfargo.com" & @CRLF & _
"apply.wellsfargo.com" & @CRLF & _
"wapppply.wellsfargo.com" & @CRLF & _
"test.wellsfargo.com" & @CRLF & _
"lending.wf.com" & @CRLF & _
"lending-loans.wf.com" & @CRLF & _
"yourmortgageapp.wf.com" & @CRLF & _
"personal-loan.wf.com" & @CRLF & _
"personalloans.wf.com" & @CRLF & _
"wellsfargo.com/werasefefraewr/adsfgdsfgsdfrg/dersgesrg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")