// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(personal-loan|yourmortgageapp|lending).wf.com|^wellsfargo.com|^apply.wellsfargo.com").unwrap();
let string = "wellsfargo.com
apply.wellsfargo.com
wapppply.wellsfargo.com
test.wellsfargo.com
lending.wf.com
lending-loans.wf.com
yourmortgageapp.wf.com
personal-loan.wf.com
personalloans.wf.com
wellsfargo.com/werasefefraewr/adsfgdsfgsdfrg/dersgesrg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}