$re = '/^(personal-loan|yourmortgageapp|lending).wf.com|^wellsfargo.com|^apply.wellsfargo.com/m';
$str = 'wellsfargo.com
apply.wellsfargo.com
wapppply.wellsfargo.com
test.wellsfargo.com
lending.wf.com
lending-loans.wf.com
yourmortgageapp.wf.com
personal-loan.wf.com
personalloans.wf.com
wellsfargo.com/werasefefraewr/adsfgdsfgsdfrg/dersgesrg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);